Treghet ved utstempling og innlasting av Timeliste
Incident Report for Tidsbanken
Resolved
This incident has been resolved.
Posted Jun 21, 2023 - 17:03 CEST
Investigating
We are currently investigating this issue.
Posted Jun 21, 2023 - 16:26 CEST
This incident affected: Application.